1128 N Queens Puzzle(20 分)(C++)

The "eight queens puzzle" is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing Nnon-attacking queens on an N×N chessboard. (From Wikipedia - "Eight queens puzzle".)

Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q​1​​,Q​2​​,⋯,Q​N​​), where Q​i​​ is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens' solution.

8q.jpg   9q.jpg
Figure 1   Figure 2

Input Specification:

Each input file contains several test cases. The first line gives an integer K (1<K≤200). Then K lines follow, each gives a configuration in the format "N Q​1​​ Q​2​​ ... Q​N​​", where 4≤N≤1000 and it is guaranteed that 1≤Q​i​​≤N for all i=1,⋯,N. The numbers are separated by spaces.

Output Specification:

For each configuration, if it is a solution to the N queens problem, print YES in a line; or NO if not.

Sample Input:

4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4

Sample Output:

YES
NO
NO
YES

刚开始拿到题,心想20分的题......出八皇后吗?

然后定睛一看,噢~~~~只是让你判断时候满足所有点不在同一条线上(行、列、对角线)

你把整个棋盘想象成一个坐标平面,初中数学嘛~出现点的地方(x,y),x;y;x-y标记一下,嘿嘿

#include<iostream>
#include<cstdio>
using namespace std;
bool row[1005],a_c[1005],c_a[1005];
int main(){
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        fill(row,row+1005,false);
        fill(a_c,a_c+1005,false);
        fill(c_a,c_a+1005,false);
        int k;
        scanf("%d",&k);
        bool flag=true;
        for(int j=1;j<=k;j++){
            int temp;
            scanf("%d",&temp);
            if(flag==false)
                continue;
            if(row[temp]==true)
                flag=false;
            else
                row[temp]=true;
            if(temp>=j){
                if(a_c[temp-j]==true)
                    flag=false;
                else
                    a_c[temp-j]=true;
            }
            else if(j>=temp){
                if(c_a[j-temp]==true)
                    flag=false;
                else
                    c_a[j-temp]=true;
            }
        }
        if(flag==true)
            printf("YES\n");
        else
            printf("NO\n");
    }
}

猜你喜欢

转载自blog.csdn.net/qq_41562704/article/details/82501690