【acm2017】字符串统计

***题目:
Problem Description
对于给定的一个字符串,统计其中数字字符出现的次数。

Input
输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。

Output
对于每个测试实例,输出该串中数值的个数,每个输出占一行。

Sample Input
2
asdfasdf123123asdfasdf
asdf111111111asdfasdfasdf

Sample Output
6
9***

代码:

#include<iostream>
#include<cstring> 
using namespace std;
int main(){
	int n;
	cin>>n;
	getchar();
	while(n--){
		int count=0; 
		char s[100];
		cin.getline(s,100);
		for(int i=0;i<strlen(s);i++){
			if(s[i]>='0'&&s[i]<='9'){
				count++;
			}
		}
		cout<<count<<endl;
	}
	return 0;
}

分析:主要注意一下当输入n的时候,要把缓冲区的那个回车符给吸收掉

发布了42 篇原创文章 · 获赞 18 · 访问量 403

猜你喜欢

转载自blog.csdn.net/weixin_42918559/article/details/104042200