字符串统计 (hdu2017)

2017 字符串统计

Problem Description
  对于给定的一个字符串,统计其中数字字符出现的次数。

Input
  输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。

Output
  对于每个测试实例,输出该串中数值的个数,每个输出占一行。

Sample Input
  2
asdfasdf123123asdfasdf
asdf111111111asdfasdfasdf

Sample Output


6
9


代码:

#include<stdio.h>  
#include<string.h>  
int main()  
{  
    int n,c,i;  
    char a[1010];  
    while(scanf("%d",&n)!=EOF)  
    {  
        while(n--)  
        {  
              
            getchar();  
            scanf("%s",a);  
            c= 0;  
            for(i = 0;a[i] != '\0';i ++)  
            {  
                if(a[i] >='0' && a[i] <= '9')  
                    c++;  
            }  
                printf("%d\n",c);  
        }  
    }  
      
    return 0;  
}  

猜你喜欢

转载自blog.csdn.net/wan_ide/article/details/80765702