hdu 2017 字符串统计【JAVA】

字符串统计

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 97377    Accepted Submission(s): 53487


Problem Description
对于给定的一个字符串,统计其中数字字符出现的次数。
 

Input
输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。
 

Output
对于每个测试实例,输出该串中数值的个数,每个输出占一行。
 

Sample Input
 
  
2 asdfasdf123123asdfasdf asdf111111111asdfasdfasdf
 

Sample Output
 
  
6 9


水题,一步一个脚印。。

import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        // TODO Auto-generated method stub
        Scanner sc = new Scanner(System.in);
        int num = sc.nextInt();
        sc.nextLine();
        while(num-- > 0)
        {
            int count = 0;
            String line = sc.nextLine();
            for(int i = 0;i < line.length();i++)
            {
                char ch = line.charAt(i);
                if(ch >= '0' && ch <= '9')
                {
                    count++;
                }
            }
            System.out.println(count);
        }
    }

}

猜你喜欢

转载自blog.csdn.net/qq_34229351/article/details/80049433