【水】HDU 2017 字符串统计

Time Limit: 2000/1000 MS (Java/Others)

Memory Limit: 65536/32768 K (Java/Others)
[显示标签]
Description
对于给定的一个字符串,统计其中数字字符出现的次数。
Input
输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。
Output
对于每个测试实例,输出该串中数值的个数,每个输出占一行。
Sample Input

2
asdfasdf123123asdfasdf
asdf111111111asdfasdfasdf

Sample Output

6
9

Hint
lcy
Source
  C语言程序设计练习(三)  
Related problem
2015 2013 2012 2010 2016

遍历一下再做判断就好了啊.这里用的了string,跟字符串差不多,不过其长度用size()得出。

代码如下:

#include <iostream>
#include <string.h>
using namespace std;

int main ()
{
int n;
cin>>n;
while(n--)
{
string a;
int count=0;
cin>>a;
for(int i=0;i<a.size();i++)
{
if(a[i]<='9'&&a[i]>='0')
    count++;
}
cout<<count<<endl;

}

}

猜你喜欢

转载自blog.csdn.net/qq_41627235/article/details/82799487