acm 字符串替换

字符串替换

时间限制:3000 ms  |  内存限制:65535 KB

难度:2

输入

输入包含多行数据

每行数据是一个字符串,长度不超过1000
数据以EOF结束

输出

对于输入的每一行,输出替换后的字符串

样例输入

you are what you do

样例输出

we are what we do

描述

编写一个程序实现将字符串中的所有"you"替换成"we"

#include<stdio.h>
#include<string.h>

int main()
{
 char ch[100];
 
 int t;
 
 int i;
 
 int j;
 
 while(gets(ch)){             //使用gets获得输入的字符串
  
  t = strlen(ch);
  
  for(i = 0; i < t - 2; i++){
   if(ch[i] == 'y' && ch[i + 1] == 'o' && ch[i + 2] == 'u'){
    ch[i] = 'w';
    
    ch[i + 1] ='e';
    
    ch[i + 2] = '#';
   }
  }
  
  for(j = 0; j < t; j++){
    if(ch[j] == '#')
    
    continue;
    
    printf("%c", ch[j]);
   }
   
   printf("\n");
 }
 
 return 0;
}

猜你喜欢

转载自blog.csdn.net/chen1042246612/article/details/81290174