hdu_problem_2017_字符串统计

/*
*
*Problem Description
*对于给定的一个字符串,统计其中数字字符出现的次数。
*
*
*Input
*输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。
*
*
*Output
*对于每个测试实例,输出该串中数值的个数,每个输出占一行。
*
*
*Sample Input
*2
*asdfasdf123123asdfasdf
*asdf111111111asdfasdfasdf
*
*
*Sample Output
*6
*9
*
*
*Author
*lcy
*
*
*Source
*C语言程序设计练习(三)
*
*
*Recommend
*lcy
*
*/
#include<iostream>
#include<string>
using namespace std;
int cnt;
void numbers_of_string(string s) {
 cnt = 0;
 for (auto i : s) {
  if ('0' <= i && i <= '9') cnt++;
 }
 cout << cnt << endl;
}
int main() {
 int n;
 string s;
 cin >> n;
 for (int i = 0; i < n; i++) {
  cin >> s;
  numbers_of_string(s);
 }
 system("pause");
 return 0;
}

猜你喜欢

转载自blog.csdn.net/CoderMaximum/article/details/86521868