(HDU2017 C++) 字符串统计

字符串统计

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 100887 Accepted Submission(s): 55572

Problem Description

对于给定的一个字符串,统计其中数字字符出现的次数。

Input

输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。

Output

对于每个测试实例,输出该串中数值的个数,每个输出占一行。

Sample Input

2
asdfasdf123123asdfasdf
asdf111111111asdfasdfasdf

Sample Output

6
9


源代码

#include<iostream>
#include<string>
using namespace std;
int main()
{
    int n, length, number;
    string str;
    cin >> n;
    while (n--)
    {
        cin >> str;
        length = str.length();
        number = 0;
        for (int i = 0; i < length; i++)
            if (str[i] >= '0'&&str[i] <= '9')
                number++;
        cout << number << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_38780240/article/details/81536731