2019 GDUT 新生 专题Ⅰ J题

J - 二分 POJ - 1905

题目
When a thin rod of length L is heated n degrees, it expands to a new length L’=(1+n*C)*L, where C is the coefficient of heat expansion.
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment.

Your task is to compute the distance by which the center of the rod is displaced.
Input
The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.
Output
For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision.
Sample Input
1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1
Sample Output
61.329
225.020
0.000

题目大意:根据图片的意思求出杆中心位移的距离。
在这里插入图片描述
思路:二分法来求。

本人菜鸡,不会证明该式子是否单调,就直接用二分了。
代码

#include <cstdio>
#include <math.h>
const double p=0.00001;
double l,b,c;
int main(){
	while(scanf("%lf%lf%lf",&l,&b,&c)==3&&l>=0&&b>=0&&c>=0){
		double r,h,L=(1+b*c)*l;
		double left=0,right=l,mid;
		while(right-left>p){
			mid=(left+right)/2;
			r=mid/2+l*l/8/mid;
			double LL=2*r*asin(l/2/r);
			if(L<LL){
				right=mid;
			}
			else left=mid;
		}
		printf("%.3f\n",mid);
	}
	return 0;
}

题目链接

发布了32 篇原创文章 · 获赞 0 · 访问量 650

猜你喜欢

转载自blog.csdn.net/weixin_45794203/article/details/103963915