LightOJ - 1341——Aladdin and the Flying Carpet (唯一分解定理)

It’s said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin’s uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.

Input
Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.

Output
For each case, print the case number and the number of possible carpets.

Sample Input
2

10 2

12 2

Sample Output
Case 1: 1

Case 2: 2

题意:找到大于b的所有a的因子对;

思路:用唯一分解定理找到a的因子的个数除以2,在枚举所有的小于b的因子,
两者相减即为正确答案。
在这里插入图片描述
代码为

#include <iostream>
#include <cstdio>
#include <queue>
#include <algorithm>
#include <string>
#include <cstring>
#include <cmath>
#define bit(x) x&(-x)
typedef long long ll;
using namespace std;
const int mod = 1000;
const int inf = 0x3f3f3f3f;
const int maxn = 1e6+10;
ll t,len;
ll a,b;
ll s[maxn],p[maxn],v[maxn];
void per(){
    len=0;
    memset(v,0,sizeof(v));
    for(int i=2;i<maxn;i++){
        if(!v[i]){
            p[len++]=i;
        }
        for(int j=0;j<len;j++){
            if(i*p[j]>maxn)break;
            v[i*p[j]]=1;
            if(i%p[j]==0) break;
        }
    }
}
ll fen(ll n){
    ll ans=1;
    for(ll i=0;p[i]<n&&i<len;i++){
        ll res=0;
        if(n%p[i]==0){
            while(n%p[i]==0){
                res++;
                n/=p[i];
            }
        }
        ans*=(1+res);
    }
    if(n>1){
        ans*=2;
    }
    return ans;
}
int main()
{
    scanf("%lld",&t);
    per();
    for(int k=1;k<=t;k++){
        scanf("%lld %lld",&a,&b);
        if(b*b>a){
            printf("Case %d: 0\n",k);
            continue;
        }
        ll sum=fen(a);
        sum/=2;
        for(ll i=1;i<b;i++) {
            if (a % i == 0) sum--;
        }
        printf("Case %d: %lld\n",k,sum);
    }
    return 0;
}

发布了35 篇原创文章 · 获赞 25 · 访问量 822

猜你喜欢

转载自blog.csdn.net/qq_43816599/article/details/102653243
今日推荐