LIghtOJ-1341-Aladdin and the Flying Carpet (唯一分解定理)

版权声明:欢迎评论与转载,转载时请注明出处! https://blog.csdn.net/wjl_zyl_1314/article/details/84704856

原题链接:
It’s said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin’s uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.

Input
Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.

Output
For each case, print the case number and the number of possible carpets.

Sample Input
2

10 2

12 2

Sample Output
Case 1: 1

Case 2: 2
题意:
输入一个n和b,找出n的所有的因子组合(x,y)要求x*y==n,其中x,y都要大于b。
题解:
先素数打表,然后利用唯一分解定理,找出所有的因子的个数,最终除以二,得到的是所有的组合可能,再减去小于b的组合个数。
附上AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define LL long long
const int N=1e6+5;
const int NN=1e5;
int prime[NN],cnt=0;
bool vis[N];
void el()//素数打表
{
    memset(vis,0,sizeof(vis));
    for(int i=2;i<N;i++)
    {
        if(!vis[i])
        {
            prime[cnt++]=i;
            for(int j=i+i;j<N;j+=i)
            {
                vis[j]=1;
            }
        }
    }
}

int main()
{
    el();
    int t;
    LL a,b;
    scanf("%d",&t);
    for(int cas=1;cas<=t;cas++)
    {
        LL st=1;
        scanf("%lld%lld",&a,&b);
        if(a<b*b)
        {
            printf("Case %d: 0\n", cas);
            continue;
        }
        LL n=a;
        for(int i=0;i<cnt&&prime[i]*prime[i]<=a;i++)
        {
            if(a%prime[i]==0)
            {
                int num=0;
                while(a%prime[i]==0)
                {
                    a/=prime[i];
                    num++;
                }
                st*=(1+num);//约数的个数
            }
        }
        if(a>1)
            st*=2;//如果没有分解完,则剩余一个素数,则乘以(1+1—)
        st/=2;
        for(LL i=1;i<b;i++)
        {
            if(n%i==0)//去除掉所有的小于b的因子个数
                st--;
        }
        printf("Case %d: %lld\n",cas,st);
    }
    return 0;
}

欢迎评论!

猜你喜欢

转载自blog.csdn.net/wjl_zyl_1314/article/details/84704856
今日推荐