1011 World Cup Betting (20 分)(题目难读,每行找个最大值???)

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to WT and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

increasingly
越来越多地

excited
兴奋的

battles
战斗

trophy
奖杯

football betting fans
足球博彩迷

manner
方式

odd
古怪的

题意没太读懂,好像是每行找个最大值

#include<bits/stdc++.h>
#pragma GCC optimize(3)
#define max(a,b) a>b?a:b
using namespace std;
typedef long long ll;
double b[10];
char c[10];
int main(){
    int id=0;
    for(int i=1;i<=3;i++){
    	for(int j=1;j<=3;j++){
    	    double x;
    	    scanf("%lf",&x);
    	    if(x>b[i]){
    		b[i]=x;
    		if(j==1) c[i]='W';
    		else if(j==2) c[i]='T';
    		else c[i]='L';
	    }
	}
    }
    for(int i=1;i<=3;i++) cout<<c[i]<<" ";
    double ans=(b[1]*b[2]*b[3]*0.65-1)*2;
    printf("%.2f\n",ans);
    return 0;
}



发布了415 篇原创文章 · 获赞 47 · 访问量 4万+

猜你喜欢

转载自blog.csdn.net/qq_42936517/article/details/101995183