A1011 World Cup Betting (20分)

1011 World Cup Betting (20分)

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a “Triple Winning” game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results – namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner’s odd would be the product of the three odds times 65%.

For example, 3 games’ odds are given as the following:

W T L
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:
Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output Specification:
For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1
Sample Output:
T T W 39.31

题目大意:

求出三次中的最大值,然后套用公式 (4.1×3.1×2.5×65%−1)×2=39.31求解

version1

#include <stdio.h>
using namespace std;
int main(){
	char ch[3];
	double max;
	double ans=1;
	for(int i=0;i<3;i++){
		double a,b,c;
		scanf("%lf %lf %lf",&a,&b,&c);
		if(a>b&&a>c){
			max=a;
			ch[i]='W';		
		}else if(a<b&&c<b){
			max=b;
			ch[i]='T';
		}else {
			max=c;
			ch[i]='L';
		}
		ans*=max;
	}
	printf("%c %c %c %0.2f",ch[0],ch[1],ch[2],(ans*0.65-1)*2);
	return 0;	
}

verion2 更简洁一点

#include <stdio.h>
using namespace std;
int main(){
	char ch[3]={'W','T','L'};
	double ans=1;int dx;
	for(int j=0;j<3;j++){
		double max=0;
		for(int i=0;i<3;i++){
			double a;
			scanf("%lf",&a);
			if(a>max){
				max=a;
				dx=i ;
			}	}
		printf("%c ",ch[dx]);
		ans*=max;
	}
	printf("%0.2f",(ans*0.65-1)*2);
	return 0;	
}
发布了91 篇原创文章 · 获赞 9 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/WeDon_t/article/details/105258726