PAT (Advanced Level) 1011 World Cup Betting (20 分)

版权声明:转载请附链接 https://blog.csdn.net/isunLt/article/details/84494424

1011 World Cup Betting (20 分)

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.
Chinese Football Lottery provided a “Triple Winning” game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results – namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner’s odd would be the product of the three odds times 65%.
For example, 3 games’ odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

Code

#include <iostream>
#include <iomanip>
#include <cstring>

using namespace std;

const int N = 3; //N for number of games
const char rep[3] = { 'W', 'T', 'L' };

int main()
{
	float bets[N][3];
	int best_choice[N]; //记录每一场比赛最好的选项,0表示W,1表示T,2表示L
	memset(best_choice, 0.0f, sizeof(best_choice));
	for (int i = 0; i < N; i++)
		for (int j = 0; j < 3; j++)
		{
			cin >> bets[i][j];
			if (bets[i][j] > bets[i][best_choice[i]])
				best_choice[i] = j;
		}
	float sum = bets[0][best_choice[0]];
	for (int i = 0; i < N; i++)
	{
		cout << rep[best_choice[i]] << ' ';
		if (i) sum *= bets[i][best_choice[i]];
	}
	sum = (sum * 0.65 - 1) * 2;
	cout << setiosflags(ios::fixed) << setprecision(2) << sum << endl;
	return 0;
}

思路

这道题太水了,就不说了。注意输出精度为小数点后2位就行了。

猜你喜欢

转载自blog.csdn.net/isunLt/article/details/84494424