PAT-A 1011. World Cup Betting (20)(20 分

1011 World Cup Betting (20)(20 分提问

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.0  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

Input

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input

1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1

Sample Output

T T W 37.98

以下代码 结果不知道为啥错了,在不保留2位精度时,输出了37.97499999...应该是37.975,

 所以四舍五入后 并不是答案的37.98,希望各位大佬赐教啊!!!

#include <iostream>
#include<cstring> 
#include<cmath>
using namespace std;
double a[3][3]; 
double k[3];//存每一行的最值
int p[3];//存每一行最值对应下标 
double mk=-1;
int pk=0;
char s[3]={'W','T','L'};
int main(int argc, char** argv) {
	memset(k,0,sizeof(k));
	memset(p,0,sizeof(p));
	for(int i=0;i<3;i++){
		double u,v,w;
		cin>>u>>v>>w;
		a[i][0]=u;
		a[i][1]=v;
		a[i][2]=w;
		if(u>mk){
			mk=u;
			pk=0;
		}if(v>mk){
			mk=v;
			pk=1;
		}if(w>mk){
			mk=w;
			pk=2;
		}
		k[i]=mk;//max(u,max(v,w));
        p[i]=pk;	
	}
	for(int i=0;i<3;i++){
		printf("%c ",s[p[i]]);
	}
	double pdt=1.0;
	for(int i=0;i<3;i++){
		pdt*=k[i];
	}
	double ans1=(pdt*0.65-1.0)*2.0;
	printf("%.2lf\n", ans1);
	return 0;
}

下面这个是别人的代码,算法笔记上也是这个思路:

#include<iostream>
#include <cstdio>
using namespace std;
int main() {
	char c[4] = {"WTL"};
	double ans = 1.0;
	for(int i = 0; i < 3; i++) {
		double maxvalue = 0.0;
		int maxchar = 0;
		for(int j = 0; j < 3; j++) {
			double temp;
			scanf("%lf", &temp);
			if(maxvalue <= temp) {
				maxvalue = temp;
				maxchar = j;
			}
		}
		ans *= maxvalue;
		printf("%c ", c[maxchar]);
	}
	printf("%.2f", (ans * 0.65 - 1) * 2);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qian2213762498/article/details/81186169