【笨方法学PAT】1011 World Cup Betting(20 分)

版权声明:欢迎转载,请注明来源 https://blog.csdn.net/linghugoolge/article/details/82621425

一、题目

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to WT and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

扫描二维码关注公众号,回复: 3970176 查看本文章

Sample Output:

T T W 39.31

二、题目大意

给定三个比赛的赔率,求可以获取的最大收益。

三、考点

模拟

四、解题思路

1、题目比较简单,直接比较大小就可以了。

2、考虑到题目的扩展性,使用数组存储;也可以联机算法,变读取,变处理,减小一个循环,但笨方法,思路更加清晰,降低出错的概率。

五、代码

#include<iostream>
using namespace std;

int main() {
	float game[3][3];
	char int2char[3] = { 'W','T','L' };
	//读取数据
	for (int i = 0; i < 3; i++) {
		for (int j = 0; j < 3; j++) {
			cin >> game[i][j];
		}
	}

	//获得每次比赛的最大值
	float ans_win = 1.0;
	for (int i = 0; i < 3; i++) {
		float ans_max = 0.0;
		int ans_id ;
		for (int j = 0; j < 3; j++) {
			if (game[i][j] > ans_max) {
				ans_max = game[i][j];
				ans_id = j;
			}
		}
		//输出结果
		cout << int2char[ans_id] << " ";
		ans_win *= ans_max;
	}
	printf("%.2f", (ans_win*0.65 - 1) * 2);
	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/linghugoolge/article/details/82621425
今日推荐