[C/C++] 1011 World Cup Betting (20)(20 分)

1011 World Cup Betting (20)(20 分)

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a “Triple Winning” game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results – namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner’s odd would be the product of the three odds times 65%.

For example, 3 games’ odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.0  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

Input

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input

1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1

Sample Output

T T W 37.98

连题都没怎么看懂。。。。。。我的这个英语水平,但是瞎做出来了,看起来有代码重复

#include<stdio.h> 

int main()
{   
    const int n=3;
    double a[3][3],prf=1.0;
    for(int i=0;i<n;i++){
        for(int j=0;j<n;j++){
            scanf("%lf",&a[i][j]);
        }
    } 
    for(int i=0;i<n;i++){
        if(a[i][0]>a[i][1]&&a[i][0]>a[i][2]){
            printf("W ");
            prf*=a[i][0];
        } 
        if(a[i][1]>a[i][0]&&a[i][1]>a[i][2]){
            printf("T ");
            prf*=a[i][1];
        } 
        if(a[i][2]>a[i][0]&&a[i][2]>a[i][1]){
            printf("L ");
            prf*=a[i][2];
        } 
    }
    prf=(prf*0.65-1)*2;
    printf("%.2f\n",prf);

    return 0;
 } 

受题目影响,看起来像是个二维的,就建了个2D数组,其实不用,在输入一组3个数之后,记住最大的数代表的字母(下标),再把结果累乘就行柳小姐姐的传送门

猜你喜欢

转载自blog.csdn.net/dulongxiang/article/details/81590338