PAT甲级真题——1011 World Cup Betting (20 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_29978597/article/details/85766540

1011 World Cup Betting (20 分)

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.
Chinese Football Lottery provided a “Triple Winning” game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results — namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner’s odd would be the product of the three odds times 65%.
For example, 3 games’ odds are given as the following:
W T L
1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1
To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.13.02.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

Input

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input

1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1

Sample Output

T T W 37.98

题目大意:

三场比赛,选择赔率最高的选项,全赢能赢多少钱。

题目解析:

签到题。

具体代码:

#include<iostream>
using namespace std;
int main() {
	double A[3],num=1.0;
	int R[3],max;
	for(int i=0; i<3; i++) {
		cin>>A[0]>>A[1]>>A[2];
		max=0;
		for(int j=1; j<3; j++) {
			if(A[j]>A[max])
				max=j;
		}
		R[i]=max;
		num*=A[max];
	}
	num=(num*0.65-1)*2;
	char k[]="WTL";
	for(int i=0;i<3;i++)
		printf("%c ",k[R[i]]);
	printf("%.2f",num);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_29978597/article/details/85766540
今日推荐