1051 Pop Sequence (25 分)(栈模拟,注意初始化)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO
#include<bits/stdc++.h>
#pragma GCC optimize(3)
#define max(a,b) a>b?a:b
using namespace std;
typedef long long ll;
const int N=1e3+5;
int s[N],top,a[N];
int m,n,k;
bool judge(){
	int pos=1;
	for(int i=1;i<=n;i++){
		s[++top]=i;
		if(top>m) return false;
		while(top>0&&s[top]==a[pos]){
			top--;
			pos++;
		} 
	}
	return pos>n;
}
int main(){
    scanf("%d%d%d",&m,&n,&k);
    while(k--){
    	top=0;
    	for(int i=1;i<=n;i++) scanf("%d",&a[i]);
    	if(judge()) printf("YES\n");
    	else printf("NO\n");
    }
    return 0;
}





发布了415 篇原创文章 · 获赞 47 · 访问量 4万+

猜你喜欢

转载自blog.csdn.net/qq_42936517/article/details/103267895