1051 Pop Sequence (25分)/栈模拟/循环条件控制

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:
YES
NO
NO
YES
NO

这题拿到没有想到解题思路,看了柳神的解析之后知道了大致思路。但是循环条件的控制也还是有些难度,最后还是参照柳神的代码才补全修正。还是这方面的训练太少了。

#include<iostream>
#include<stack>
#include<vector>
using namespace std;
int main() {
	int m, n, k;
	cin >> m >> n >> k;
	vector<int> v(n+1);
	while (k--) {
		for (int i = 1; i <= n; i++) {
			scanf("%d", &v[i]);
		}
		stack<int> s;
		int i = 1, j = 1;
		while (j <= n) {  
			s.push(j++);
			if (s.size() > m) break; //超过给定的栈的最大容量
			while (!s.empty() && s.top() == v[i]) {
				s.pop();
				i++;
			}
		}		
		printf("%s\n", i == n+1 ? "YES" : "NO");
	}
	return 0;
}
发布了28 篇原创文章 · 获赞 5 · 访问量 608

猜你喜欢

转载自blog.csdn.net/weixin_43590232/article/details/104091282