PAT--1051 Pop Sequence (25 分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO
#include <iostream>
#include <bits/stdc++.h>
#include <cstring>
using namespace std;

int main()
{
    int n,m,k;
    cin>>n>>m>>k;
    while(k--){
        int a[m];
        int index = 0;
        int lenth = 0;
        stack<int> s;
        for(int i=0;i<m;i++){
            cin>>a[i];
        }

        for(int i=1;i<=m;i++){
            s.push(i);
            if(s.size()>n){
                break;
            }
            while(!s.empty()&&s.top()==a[index]){
                s.pop();
                index++;
            }
        }

        if(index==m){
            cout<<"YES"<<endl;
        }else{
            cout<<"NO"<<endl;
        }
    }
    return 0;
}

 分析:

该题刚开始以为pop出可以不输入在重新push进,所以不知道思路,结果看到大佬的提示的才知道,pop直接输出。

思路:

模拟栈,按照顺序push进栈,进入时判断:如果是栈顶并且是需输出的元素,则从栈中输出,并继续判断下一个是否是需要继续输出的元素,如果是就一直pop,如果不是继续push。、

知道最后,如果index,即输出的元素和数组长度一样,即可以,否则不可以。

猜你喜欢

转载自blog.csdn.net/jackson_j/article/details/98657666