(难)A1051 Pop Sequence (25 分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

题意:

有一个容量限制为 M 的栈,先分别把 1,2,3,... ,n 依次入栈,并给出一系列出栈顺序,问这些出栈顺序是否可能

输入:第一行三个数(均不超过1000)分别为:栈的容量 M, 每个序列给定数字个数,给定多少个序列

     后面每一行均为出栈顺序

思路:

将给定出栈序列存储于 arr[maxn] 数组中,定义 current = 1,用 arr[current] 表示当前给定序列要出栈的元素。从 1 到 N 依次枚举入栈,入栈之后判断 size(用 flag 标志),判断是否需要出栈,直到枚举完 1 到 N。此时如果栈为空,且 flag 为 true,输出 YES 即可。

知识点:

stack

  1. 添加 #include <stack>, using namespace std;
  2. 定义:stack <typename> name;例如 stack<int> st;
  3. 入栈:st.push(x);
  4. 获取栈顶元素:st.top()
  5. 出栈:st.pop();
  6. 判空:st.empty() == true
  7. 返回元素个数:st.size()

注意:

  1. 在每一个栈序列输入之前,一定要清空 st
#include <cstdio>
#include <stack>
using namespace std;
const int maxn = 1010;
int arr[maxn];      //保存题目给定的出栈序列
stack<int> st;
int main(){
    int m, n, T;
    scanf("%d%d%d", &m, &n, &T);
    while(T--){
        while(!st.empty()){     //栈非空,清空栈
            st.pop();
        }
        for(int i = 1; i <= n; i++){
            scanf("%d", &arr[i]);
        }
        int current = 1;          //指向给定序列中的待出栈序列
        bool flag = true;
        for(int i = 1; i <= n; i++){
            st.push(i);
            if(st.size() > m){
                flag = false;
                break;
            }
            while(!st.empty() && st.top() == arr[current]){
                st.pop();
                current++;
            }
        }
        if(st.empty() == true && flag == true){
            printf("YES\n");
        }
        else{
            printf("NO\n");
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_35093872/article/details/87806231