1051 Pop Sequence (25 分)(模拟)

1051 Pop Sequence (25 分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

是模拟

代码

#include<bits/stdc++.h>
using namespace std;
stack<int>st;
int digit[1005];
int main() 
{
    int n, m ,t;
    cin>> m >>n >>t;
    while(t--)
    {
    	while(!st.empty())
    		st.pop();
    	for(int i = 1; i <= n; i++)
    		scanf("%d",&digit[i]);
    	int cnt = 1;
    	int flag = 1;
		for(int i = 1; i <= n; i++)
    	{
    		st.push(i);
    		if(st.size() > m){
    			flag = 0;
    			break; //表示当前已经大于了 
			}
    		while(!st.empty() && st.top() == digit[cnt]) 
    		{
    			st.pop();
    			cnt++;
			}
		}
		if(st.empty() && flag)
			cout<<"YES"<<endl;
		else 
			cout<<"NO"<<endl;
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/galesaur_wcy/article/details/84668166