PAT 1051 Pop Sequence (25 分)

1051 Pop Sequence (25 分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.


Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.


Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO




解析

这题很有意思。要求你模拟元素出栈。




Code:

#include<stack>
#include<algorithm>
#include<cstdio>
#include<iostream>
#include<vector>
using namespace std;
const char out1[]= "YES" ;
const char out2[] = "NO";
bool check(const vector<int>& arr,int cap) {
	stack<int> S;
	int j = 1,max = arr.size(),len =arr.size();
	auto current = 0;
	while (j <= len) {
		S.push(j++);
		if (S.size() > cap)
			return false;
		while (!S.empty() && S.top() == arr[current]) {
			S.pop();
			current++;
		}
	}
	return S.empty();
}
int main()
{
	int M, N, K;
	scanf("%d %d %d", &M, &N, &K);
	for (int i = 0; i < K; i++) {
		vector<int> arr(N);
		for (int j = 0; j < N; j++)
			scanf("%d", &arr[j]);
		printf("%s\n", check(arr,M) ? out1: out2);
	}
}

猜你喜欢

转载自blog.csdn.net/weixin_41256413/article/details/84104060