PAT (Advanced Level) Practice 1051 Pop Sequence (25分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

实现代码:

#include<iostream>
#include<stack>
#include<queue>
using namespace std;
int n, m, k;
bool judge(queue<int> q) {
	stack<int> s;
	int i = 1;
	while (q.size()) {
		s.push(i);
		if (s.size() > m)
			return false;
		while (s.size()&&s.top() == q.front()) {
			s.pop();
			q.pop();
		}
		i++;
	}
	return true;
}
int main(void) {
	cin >> m >> n >> k;
	for (int i = 0; i < k; i++) {
		int data;
		queue<int> q;
		for (int j = 0; j < n; j++) {		
			cin >> data;
			q.push(data);
		}
		if (judge(q))
			cout << "YES";
		else
			cout << "NO";
		cout << endl;
	}
}
原创文章 165 获赞 197 访问量 8万+

猜你喜欢

转载自blog.csdn.net/weixin_43751983/article/details/105641398