D - Palindrome subsequence

In mathematics, a subsequence is a sequence that can be derived from another sequence by deleting some elements without changing the order of the remaining elements. For example, the sequence <A, B, D> is a subsequence of <A, B, C, D, E, F>.
(http://en.wikipedia.org/wiki/Subsequence)

Given a string S, your task is to find out how many different subsequence of S is palindrome. Note that for any two subsequence X = <S x1, S x2, …, S xk> and Y = <S y1, S y2, …, S yk> , if there exist an integer i (1<=i<=k) such that xi != yi, the subsequence X and Y should be consider different even if S xi = S yi. Also two subsequences with different length should be considered different.

Input

The first line contains only one integer T (T<=50), which is the number of test cases. Each test case contains a string S, the length of S is not greater than 1000 and only contains lowercase letters.

Output

For each test case, output the case number first, then output the number of different subsequence of the given string, the answer should be module 10007.

Sample Input

4
a
aaaaa
goodafternooneveryone
welcometoooxxourproblems

Sample Output

Case 1: 1
Case 2: 31
Case 3: 421
Case 4: 960

这道题一开始用的cout,结果tle了
注意在取模之前,如果有减法的话需要先加mod再取模

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int N = 1005;
const int mod = 10007;
const int INF = 0x3f3f3f3f;

char s[N];
int dp[N][N];

int main(void)
{
	//ios::sync_with_stdio(false);
	int t, n, id = 1;;
	cin >> t;
	while (t--){
		cin >> s + 1;
		int n = strlen(s + 1);
		memset(dp, 0, sizeof dp);
		for (int i = 1; i <= n; i++){
			dp[i][i] = 1;
		}
		for (int len = 2; len <= n; len++){
			for (int i = 1; i <= n - len + 1; i++){
				int j = i + len - 1;
				dp[i][j] = dp[i + 1][j] + dp[i][j - 1] - dp[i + 1][j - 1]; 
				dp[i][j] = (dp[i][j] + mod) % mod;
				if (s[i] == s[j]){
					dp[i][j] += dp[i + 1][j - 1] + 1;
					dp[i][j] %= mod;
				}
			}
		}
		printf("Case %d: %d\n", id++, dp[1][n]);
	}
	return 0;
}
发布了162 篇原创文章 · 获赞 18 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/weixin_43772166/article/details/103508107