Palindrome subsequence HDU - 4632

HDU - 4632

 

In mathematics, a subsequence is a sequence that can be derived from another sequence by deleting some elements without changing the order of the remaining elements. For example, the sequence <A, B, D> is a subsequence of <A, B, C, D, E, F>. 
(http://en.wikipedia.org/wiki/Subsequence) 

Given a string S, your task is to find out how many different subsequence of S is palindrome. Note that for any two subsequence X = <S x1, S x2, ..., S xk> and Y = <Sy1, S y2, ..., S yk> , if there exist an integer i (1<=i<=k) such that xi != yi, the subsequence X and Y should be consider different even if S xi = S yi. Also two subsequences with different length should be considered different.

Input

The first line contains only one integer T (T<=50), which is the number of test cases. Each test case contains a string S, the length of S is not greater than 1000 and only contains lowercase letters.

Output

For each test case, output the case number first, then output the number of different subsequence of the given string, the answer should be module 10007.

Sample Input

4
a
aaaaa
goodafternooneveryone
welcometoooxxourproblems

Sample Output

Case 1: 1
Case 2: 31
Case 3: 421
Case 4: 960

题意:判断一个字符串中,子串为回文字符串的个数,样例2中 aaaaa ,ans = C(5,1)+C(5,2)+C(53)+C(54),+C(5,5) = 31。(C为组合数)

题解:简单的区间dp ,dp [i] [j] 表示 i ~ j  最多的回文字符串个数,初始化 dp [i] [j] = dp [i] [j-1] + dp [i+1] [j] - dp [i+1] [j-1] ,若

s[i] = s[j] ,dp [i] [j] += dp [i+1] [j-1]。

ac代码:

//#include<bits/stdc++.h>
//#include <unordered_map>
//#include<unordered_set>
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<set>
#include<climits>
#include<queue>
#include<cmath>
#include<stack>
#include<map>
using namespace std;
#define LL long long
#define ULL unsigned long long
#define MT(a,b) memset(a,b,sizeof(a))
const int INF  =  0x3f3f3f3f;
const int ONF  = -0x3f3f3f3f;
const int O    =  1e5;
const int MOD  =  1e4+7;
const int maxn =  1e3+5;
const int N    =  1e9+5;
const double PI  =  3.141592653589;
const double E   =  2.718281828459;

int dp[maxn][maxn];

int main()
{
    int T;scanf("%d",&T);
    int l =0;
    while(T--)
    {
        char s[maxn];scanf("%s",s);
        MT(dp,0);
        int n = strlen(s);
        for(int len = 1;len <= n; len ++)
            for(int i = 0;i < n; i++)
        {
            int j = len + i -1;
            if(j>= n) break;
            dp[i][j] = (dp[i][j-1] + dp[i+1][j] - dp[i+1][j-1] + MOD) % MOD;
            if(s[i]==s[j]) dp[i][j]  = (dp[i][j] + dp[i+1][j-1] + 1) % MOD;
        }
        printf("Case %d: %d\n",++l,dp[0][n-1]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Mannix_Y/article/details/82259368
今日推荐