Palindrome subsequence

In mathematics, a subsequence is a sequence that can be derived from another sequence by deleting some elements without changing the order of the remaining elements. For example, the sequence <A, B, D> is a subsequence of <A, B, C, D, E, F>.
(http://en.wikipedia.org/wiki/Subsequence)

Given a string S, your task is to find out how many different subsequence of S is palindrome. Note that for any two subsequence X = <S x1, S x2, ..., S xk> and Y = <S y1, S y2, ..., S yk> , if there exist an integer i (1<=i<=k) such that xi != yi, the subsequence X and Y should be consider different even if S xi = S yi. Also two subsequences with different length should be considered different.

Input The first line contains only one integer T (T<=50), which is the number of test cases. Each test case contains a string S, the length of S is not greater than 1000 and only contains lowercase letters. Output For each test case, output the case number first, then output the number of different subsequence of the given string, the answer should be module 10007. Sample Input
4
a
aaaaa
goodafternooneveryone
welcometoooxxourproblems
Sample Output
Case 1: 1
Case 2: 31
Case 3: 421
Case 4: 960


T <= 50 S <= 1000 区间dp
首先,dp[i][j] 表示区间[i,j]上有多少个回文序列,序列可以是不连续的
(1)dp[i][j] = dp[i][j-1] + dp[i+1][j] - dp[i+1][j-1];
dp[i][j] = (dp[i][j]+mod) % mod;
这里要+mod的原因是,有可能dp[i][j-1] = 10008,然后取模之后变成了1
然后 dp[i+1][j-1] = 10006 取模完还是10006
这样相减就会出来负数,但是本身dp[i][j-1] = 10008 减完应该是正的,
由于取模的原因变成的负数所以要加上mod,这样结果才是正的
(2)如果两端是一样的,假设都是 x 。 那么把s[i],s[j] 单拿出来就会构成一个新的回文序列 x,x
在区间[i+1,l-1]上的回文序列拿出来之后,在两边同时加上x...x 这样又会是一个新的回文序列,
if(s[i]==s[j]){
    dp[i][j] += dp[i+1][j-1] +1;
    dp[i][j] %= mod;
}

#include<iostream>
#include<cstring>
using namespace std;
const int maxn = 1005;
const int mod = 10007;
char s[maxn]; 
int dp[maxn][maxn];
int main()
{
	int T,t,len;
	cin>>T;
	for(t=1;t<=T;t++){
		cin>>(s+1);
		len = strlen (s+1);
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=len;i++){
			dp[i][i] = 1;
		}
		for(int k =2;k<=len;k++){
			for(int i=1;i+k-1<=len;i++){
				int j = i+k-1;
				dp[i][j] = dp[i][j-1] + dp[i+1][j] - dp[i+1][j-1];
				dp[i][j] = (dp[i][j]+mod) % mod;
				if(s[i]==s[j]){
					dp[i][j] += dp[i+1][j-1] +1;
					dp[i][j] %= mod;
				}
			}
		}
		printf("Case %d: %d\n",t,dp[1][len]);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_39562286/article/details/80412256
今日推荐