HDU 4632 Palindrome subsequence(区间dp)

http://acm.hdu.edu.cn/showproblem.php?pid=4632

Problem Description

In mathematics, a subsequence is a sequence that can be derived from another sequence by deleting some elements without changing the order of the remaining elements. For example, the sequence <A, B, D> is a subsequence of <A, B, C, D, E, F>.
(http://en.wikipedia.org/wiki/Subsequence)

Given a string S, your task is to find out how many different subsequence of S is palindrome. Note that for any two subsequence X = <Sx1, Sx2, …, Sxk> and Y = <Sy1, Sy2, …, Syk> , if there exist an integer i (1<=i<=k) such that xi != yi, the subsequence X and Y should be consider different even if Sxi = Syi. Also two subsequences with different length should be considered different.

Input

The first line contains only one integer T (T<=50), which is the number of test cases. Each test case contains a string S, the length of S is not greater than 1000 and only contains lowercase letters.

Output

For each test case, output the case number first, then output the number of different subsequence of the given string, the answer should be module 10007.

Sample Input

4
a
aaaaa
goodafternooneveryone
welcometoooxxourproblems

Sample Output

Case 1: 1
Case 2: 31
Case 3: 421
Case 4: 960

题意就是求一个字符串的回文子序列个数
状态转移方程不好想
代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn = 1005;
const int mod=1e4+7;
int dp[maxn][maxn];
char str[maxn];
int main()
{
    int t;
    scanf("%d",&t);
    for(int i=1;i<=t;i++){
        memset(dp,0,sizeof dp);
        scanf("%s",str+1);
        int length=strlen(str+1);
        for(int i=1;i<=length;i++) dp[i][i]=1;
        for(int len=2;len<=length;len++){
            for(int l=1;l+len-1<=length;l++){
                int r=l+len-1;
                if(str[l]==str[r]) dp[l][r]=(dp[l][r-1]+dp[l+1][r]+1)%mod;
                else dp[l][r]=(dp[l][r-1]+dp[l+1][r]-dp[l+1][r-1]+mod)%mod;
            }
        }
        printf("Case %d: %d\n",i,dp[1][length]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/blue_kid/article/details/79180115
今日推荐