【HDU】4632Palindrome subsequence-dp回文串

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65535 K (Java/Others)
Total Submission(s): 4077    Accepted Submission(s): 1734


 

Problem Description

In mathematics, a subsequence is a sequence that can be derived from another sequence by deleting some elements without changing the order of the remaining elements. For example, the sequence <A, B, D> is a subsequence of <A, B, C, D, E, F>.
(http://en.wikipedia.org/wiki/Subsequence)

Given a string S, your task is to find out how many different subsequence of S is palindrome. Note that for any two subsequence X = <Sx1, Sx2, ..., Sxk> and Y = <Sy1, Sy2, ..., Syk> , if there exist an integer i (1<=i<=k) such that xi != yi, the subsequence X and Y should be consider different even if Sxi = Syi. Also two subsequences with different length should be considered different.

 

Input

The first line contains only one integer T (T<=50), which is the number of test cases. Each test case contains a string S, the length of S is not greater than 1000 and only contains lowercase letters.

 

Output

For each test case, output the case number first, then output the number of different subsequence of the given string, the answer should be module 10007.

 

Sample Input

 

4 a aaaaa goodafternooneveryone welcometoooxxourproblems

 

Sample Output

 

Case 1: 1 Case 2: 31 Case 3: 421 Case 4: 960

 

Source

2013 Multi-University Training Contest 4

 

Recommend

zhuyuanchen520   |   We have carefully selected several similar problems for you:  6447 6446 6445 6444 6443 

题目大意:给定一个字符串,求出字符串中的回文串的数量

思路:其实还是挺好写的,就区间dp枚举终点位置判断就行了,这个取模还是挺懵的。。。

状态转移方程:

dp[j][i]=(dp[j+1][i]+dp[j][i-1]-dp[j+1][i-1]+mod)%mod;(有点类似于文式图中的两个有交集的集合求并集了)

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#define mod 10007
#define maxn 1005
using namespace std;

char s[maxn];
int dp[maxn][maxn];

int main()
{
    int t,cas=1;
    cin>>t;
    while(t--)
    {
        cin>>s;
        int n=strlen(s);
        for(int i=0; i<n; i++)
            dp[i][i]=1;
        for(int i=1; i<n; i++)
            for(int j=i-1; j>=0; j--)
            {
                dp[j][i]=(dp[j+1][i]+dp[j][i-1]-dp[j+1][i-1]+mod)%mod;
                if(s[j]==s[i])
                {
                    dp[j][i]=(dp[j][i]+dp[j+1][i-1]+1+mod)%mod;
                }
            }

        printf("Case %d: %d\n",cas++,dp[0][n-1]);
    }
}

猜你喜欢

转载自blog.csdn.net/wentong_Xu/article/details/82262063