HDU1003-Max Sum-(基础动态规划)

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

思路:

1.动态规划,转化方程:a[i]=max(a[i-1],a[i-1]+a[i]);

2.注意输出格式,否则Presentation Error;

#include<iostream>
using namespace std;
int a[100010],t,n,flagi,flagj,start;//flag用于记录位置 
long long int  sumMAX;//,dp[100010];
int main(){
	int k=1,m;
	cin>>t;
	m=t;//m用于控制输出格式,防止演示出错 
	while(t--){
		flagi=flagj=start=0;
		cin>>n;
		for(int i=0;i<n;i++)
			cin>>a[i];
		sumMAX=a[0];
		for(int i=1;i<n;i++){ 
			//a[i]=max(a[i-1],a[i-1]+a[i])
			if(a[i-1]>=0){
				a[i]=a[i]+a[i-1];
			}
			else{
				start=i;
			}
			if(a[i]>sumMAX){
				sumMAX=a[i];
                flagi=start;
                flagj= i;
			}	
		} 
		cout<<"Case "<<k++<<":"<<endl;
		if(m==1||m==k-1) 
			cout<<sumMAX<<" "<<flagi+1<<" "<<flagj+1<<endl;
		else
			cout<<sumMAX<<" "<<flagi+1<<" "<<flagj+1<<endl<<endl;
	}
} 
/*Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4

Case 2:
7 1 6*/
发布了73 篇原创文章 · 获赞 27 · 访问量 1232

猜你喜欢

转载自blog.csdn.net/queque_heiya/article/details/103837311
今日推荐