SDUT ACM M--二分查找(基于C语言)



M--二分查找

Time Limit: 600 ms  Memory Limit: 65536 KiB

Problem Description

给出含有n个数的升序序列,保证序列中的数两两不相等,这n个数编号从1 到n。
然后给出q次询问,每次询问给出一个数x,若x存在于此序列中,则输出其编号,否则输出-1。

Input

单组输入。首先输入一个整数n(1 <= n && n <= 3000000),接下的一行包含n个数。
再接下来的一行包含一个正整数q(1 <= q && q <= 10000),表示有q次询问。
再接下来的q行,每行包含一个正整数x。

Output

对于每次询问,输出一个整数代表答案。

Sample Input

5
1 3 5 7 9
3
1
5
8

Sample Output

1
3
-1

Hint

 

Source

#include <stdio.h>
#include <stdlib.h>
int a[3000010];
int st(int a[],int l,int r,int key)
{
    int mid;
    if(l<=r)
    {
        mid=(l+r)/2;
        if(a[mid]==key)
            return mid;
        if(a[mid]>key) return st(a,l,mid-1,key);
        else return st(a,mid+1,r,key);
    }
    if(l>r) return -1;
}
int main()
{
    int n,m,p,key,i;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=1; i<=n; i++)
            scanf("%d",&a[i]);

        scanf("%d",&m);



        for(i=1; i<=m; i++)
        {
            scanf("%d",&key);
            p=st(a,1,n,key);
            printf("%d\n",p);
        }



    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_41374539/article/details/80289904