SDUT ACM数据结构实验之链表一:顺序建立链表(基于C语言)

数据结构实验之链表一:顺序建立链表

Time Limit: 1000 ms  Memory Limit: 65536 KiB

Problem Description

输入N个整数,按照输入的顺序建立单链表存储,并遍历所建立的单链表,输出这些数据。

Input

第一行输入整数的个数N;
第二行依次输入每个整数。

Output

输出这组整数。

Sample Input

8
12 56 4 6 55 15 33 62

Sample Output

12 56 4 6 55 15 33 62

Hint

不得使用数组!

Source

#include <stdio.h>
#include <stdlib.h>
struct st {int data;struct st *next;};
int main()
{
   int i,n;
   struct st *head,*p,*tail;
   head=(struct st*)malloc(sizeof(struct st));
   head->next=NULL;
   tail=head;
   scanf("%d",&n);
   for(i=0;i<n;i++)
   {
       p=(struct st*)malloc(sizeof(struct st));
       scanf("%d",&p->data);
       p->next=NULL;
       tail->next=p;
       tail=p;
   }
   p=head;
   while(p->next!=NULL)
   {
       printf("%d ",p->next->data);
       p=p->next;
   }
  return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41374539/article/details/80285773