poj-Dividing

转载自:这位博主

描述

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

输入

Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1 2 0 0". The maximum total number of marbles will be 20000. 

The last line of the input file will be "0 0 0 0 0 0"; do not process this line.

输出

For each collection, output "Collection #k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.". 

Output a blank line after each test case.

样例输入

1 0 1 2 0 0 
1 0 0 0 1 1 
0 0 0 0 0 0 
样例输出
Collection #1:
Can't be divided.

Collection #2:
Can be divided.

解题思路:

真真是太巧妙了,原作者功底深厚,这方学习了!

就是由dfs深搜,满足和为总和的一半就结束。

还有就是注意回溯,不然如原博客评论中的0 0 3 0 3 1这个样例不能过(虽然oj能过 :)

# include<stdio.h>

int a[7],sum;
int dfs(int x)
{
	if(x==sum/2)
		return 1;
	for(int i=6;i>=1;i--)
	{
	   if(a[i]>0&&x+i<=sum/2)//逆序
	   {
	       a[i]--;
		   if(dfs(x+i))
			   return 1;
		   else
			   a[i]++;//回溯
	   }
	}
   return 0;
}
int main()
{
  int i,Case=0;
  while(scanf("%d",&a[1])!=EOF)
  {
      sum=a[1];
	  for(i=2;i<=6;i++)
	  {
	    scanf("%d",&a[i]);
		sum+=a[i]*i;
	  }
	  if(sum==0)
	  {
		break;
	  }
	  Case++;
	  if(sum%2!=0)
	  {
	    printf("Collection #%d:\n",Case);
		printf("Can't be divided.\n\n");
		continue;
	  }
	  if(dfs(0)==1)
	  {
	      printf("Collection #%d:\n",Case);
		  printf("Can be divided.\n\n");
	  }
	  else
	  {
	     printf("Collection #%d:\n",Case);
		 printf("Can't be divided.\n\n");
	  }
  }
 return 0;
}

猜你喜欢

转载自blog.csdn.net/zhuixun_/article/details/80205648
今日推荐