POJ - 2785 Values whose Sum is 0(二分暴力

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

题目链接

题意:找到和为0的abcd有多少种组合

用四个循环肯定不行,对b求和,cd求和,再查找

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
using namespace std;
#define maxn 4010
int ab[maxn*maxn],cd[maxn*maxn];
int a[maxn],b[maxn],c[maxn],d[maxn];
int main()
{
	int n,k=0,z=0;
	cin>>n;
	for(int i=0;i<n;i++)
	{
		cin>>a[i]>>b[i]>>c[i]>>d[i];
	}
	for(int i=0;i<n;i++)
	{
		for(int j=0;j<n;j++)
		{
			ab[k++]=a[i]+b[j];
			cd[z++]=c[i]+d[j];
		}
	}
	sort(ab,ab+n*n);
	sort(cd,cd+n*n);
	int sum=0,num;
	int flag=n*n-1;
	for(int i=0;i<n*n;i++)
	{
		while (flag>=0&&ab[i]+cd[flag]>0)//优化 
			flag--;   //最小flag使sum>0;随着i的增加,ab[i]增大,flag减小 
		if(flag<0)break;
		num =flag;   
		while (ab[i]+cd[num]==0&&num>=0)  
        {
            sum++;
            num--;   
        }
    }
    cout<<sum<<endl;
}

猜你喜欢

转载自blog.csdn.net/henu_xujiu/article/details/81432310
今日推荐