POJ-27854-Values whose Sum is 0

原题
The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .
Input
The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .
Output
For each input file, your program has to write the number quadruplets whose sum is zero.
Sample Input
6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45
Sample Output
5
Hint
Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).
题意:
有四个数列,每一个数列都有n个数,先要求从四个数组中各取一个数相加为0的情况的数量。
题解:
水题一道,思想是枚举,只是这里用枚举会超时,所以使用二分,更快的查找到相同的值。
附上AC代码:

#include <iostream>
#include <algorithm>
using namespace std;
int n,a[4005][4];
int sum1[16000005],sum2[16000005];
int main()
{
    ios::sync_with_stdio(false);
    while(cin>>n)
    {
        for(int i=1;i<=n;i++)
            for(int j=0;j<=3;j++)
            cin>>a[i][j];
        int cnt=0,k=0,l=0,mid;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
        {
            sum1[k++]=a[i][0]+a[j][1];
            sum2[l++]=a[i][2]+a[j][3];
        }
        sort(sum1,sum1+k);
        sort(sum2,sum2+l);
        //for(int i=1;i<k;i++)
            //cout<<sum1[i]<<" "<<sum1[k-i-1]<<endl;
        for(int i=0;i<k;i++)
        {
            int left=0;
            int right=k-1;
            while(left<=right)//枚举超时所以二分
            {
                mid=(left+right)/2;
                if(sum1[i]+sum2[mid]==0)
                {
                    cnt++;
                    for(int j=mid+1;j<k;j++)
                    {
                        if(sum1[i]+sum2[j]!=0)
                           break;
                        else
                        cnt++;
                    }
                    for(int j=mid-1;j>=0;j--)
                    {
                        if(sum1[i]+sum2[j]!=0)
                           break;
                        else
                           cnt++;
                    }
                    break;
                }
                if(sum1[i]+sum2[mid]<0)
                    left=mid+1;
                else
                    right=mid-1;
            }
        }
        cout<<cnt<<endl;
    }
    return 0;
}

欢迎评论!

猜你喜欢

转载自blog.csdn.net/wjl_zyl_1314/article/details/83118667
今日推荐