LightOJ - 1341(算数基本定理)

B - Aladdin and the Flying Carpet  

It's said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin's uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.

Input

Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.

Output

For each case, print the case number and the number of possible carpets.

Sample Input

2

10 2

12 2

Sample Output

Case 1: 1

Case 2: 2
自己好垃圾,这道题竟然做了那么长时间,这道题大意是[b, a]有多少对因数对。这道题打眼一看就知道是算数基本定理,但是不知道怎么找到小于b的因数。枚举小于b的数,如果这个数能够整除a的话,就减去。我先用了个素数筛1e6内的素数,因为如果这个数为非素数的话,即使大于1e6但是,一定存在个小于1e6的因子,一定不要忘记这个数为素数。推的时候一定不要忘记约束条件,我就把如果这是个大于1e6的素数这个条件忘了
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>

using namespace std;
const int numsize = 1000005;
bool isprime[numsize];
int prime[numsize];
int main()
{
    memset(isprime, 1, sizeof(isprime));
    isprime[1] = false;
    int cnt = 1;
    for(int i = 2; i <= numsize; i ++)
    {
        if(isprime[i])
        {
            prime[cnt ++] = i;
        }
        for(int j = 1; j < cnt&&prime[j]*i <= numsize; j ++)
        {
            isprime[i*prime[j]] = false;
            if(i % prime[j] == 0)
                break;
        }
    }
   int t;
   scanf("%d", &t);
   int tem = 0;
   while(t --)
   {
       long long  a, b;
       scanf("%lld %lld",&a, &b);
        if(b*b >= a)
        {
            printf("Case %d: 0\n", ++tem);
            continue;
        }
       long long x = a;
       long long cnt1 = 1;
       for(int i = 1; i < cnt&&prime[i] <= x; i ++)
       {
           int c = 0;
                while(x % prime[i] == 0)
           {
               x /= prime[i];
               c ++;
           }
           cnt1 *= (c + 1);
       }
        if(x > 1)
            cnt1 *= 2;
        cnt1/= 2;
        for(int i = 1; i < b; i ++)
        {
            if(a % i == 0)
                cnt1 --;
        }
        printf("Case %d: %lld\n", ++tem, cnt1);
   }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdnulixianrui/article/details/80090935