1076 Forwards on Weibo

1076 Forwards on Weibo (30 分)
Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]
where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID’s for query.

Output Specification:
For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:
7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6
Sample Output:
4
5
题意:
在微博中,每个用户都可能被若干个其他用户关注。而当该用户发布一条信息时,他的关注者就可以看到这条信息并选择是否转发它,且转发的信息也可以被转发者的关注者再次转发,但同一用户最多只转发该信息一次(信息的最初发布者不会转发该信息)。现在给出N个用户的关注情况(即他们各自关注了哪些用户)以及一个转发层数上限L,并给出最初发布消息的用户编号,求在转发层数上限消息最多会被多少用户转发。

#include<cstdio>
#include<cstring>
#include<vector>
#include<queue>
using namespace std;
const int MAXV=1010;
struct Node
{
	int id;//结点编号
	int layer;//结点层号 
};
vector<Node> Adj[MAXV];//邻接表
bool inq[MAXV]={false};//顶点是否已被加入过队列
int BFS(int s,int L)
{
	//start为起始结点,L为层数上限
	int numForward=0;//转发数
	queue<Node> q;//BFS队列
	Node start;//定义起始结点;
	start.id=s;//起始结点编号
	start.layer=0;//起始结点层号为0
	q.push(start);//将起始结点压入队列
	inq[start.id]=true;//起始结点的编号设为已被加入过队列
	while(!q.empty())
	{
		Node topNode=q.front();//取出队首结点
		q.pop();//队首结点出队
		int u=topNode.id;//队首结点的编号
		for(int i=0;i<Adj[u].size();i++)
		{
			Node next=Adj[u][i];//从u出发能到达的结点next
			next.layer=topNode.layer+1;//next的层号等于当前结点层号加1
			//如果next的编号未被加入过队列,且next的层次不超过上限L
			if(inq[next.id]==false && next.layer<=L)
			{
				q.push(next);//入队
				inq[next.id]=true;//next的编号设为已被加入过队列
				numForward++;//转发数加1 
				 
			} 
		} 
	} 
	return numForward; 
} 
int main()
{
	Node user;
	int n,L,numFollow,idFollow;
	scanf("%d%d",&n,&L);//结点个数,层数上限
	for(int i=1;i<=n;i++)
	{
		user.id=i;//用户编号为i; 
		scanf("%d",&numFollow);//i号用户关注的人数
	    for(int j=0;j<numFollow;j++)
		{
			scanf("%d",&idFollow);//i号用户关注的用户编号
			Adj[idFollow].push_back(user);//边idFollow->i 
		} 
	} 
	int numQuery,s;
	scanf("%d",&numQuery);//查询个数
	for(int i=0;i<numQuery;i++)
	{
		memset(inq,false,sizeof(inq));//inq数组初始化
		scanf("%d",&s);//起始结点编号
		int numForward=BFS(s,L);//BFS返回转发数
		printf("%d\n",numForward); 
	} 
	return 0;
	
}

猜你喜欢

转载自blog.csdn.net/qq_37617419/article/details/89341575