1076. Forwards on Weibo (30)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/rebornyp/article/details/80141683

题目阐述

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=1000), the number of users; and L (<=6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (<=100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that are followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID’s for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:
7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6
Sample Output:
4
5


题目分析

  • 找每个查询用户的所有关注者数量(规定的层数内),使用广度优先遍历,输入数据是每个用户id及其关注的用户的id链表,所以使用链接表存的时候注意存储顺序;
  • 对每个查询的用户id做广度优先遍历,一层一层的查询,当层数达到给定的level上限时,停止查询,否则继续直到遍历完所有用户;

代码实现

#include <stdio.h>
#include <queue>
#include <vector>
using namespace std;
vector<int> adj[1005];
int b[1005];
int count(int id, int l) {
    int cnt = 0, cur = 1, num = 0, level = 0;
    queue<int> q;
    b[id] = 1;
    q.push(id);
    while (!q.empty()) {
        int temp = q.front();
        q.pop();
        cur --;
        for (int i=0; i<adj[temp].size(); i++) {
            if (!b[adj[temp][i]]) {
                b[adj[temp][i]] = 1;
                q.push(adj[temp][i]);
                num ++;
            }
        }
        if (cur == 0) {
            level ++;
            cur = num;
            cnt += cur;
            num = 0;
        }
        if (level == l) break;
    }
    return cnt;
}
int main() {
    int l, n, k;    
    scanf("%d%d", &n, &l);
    for (int i=0; i<n; i++) {
        int num, temp;
        scanf("%d", &num);
        for (int j=0; j<num; j++) {
            scanf("%d", &temp);
            adj[temp].push_back(i+1);
        }
    }
    scanf("%d", &k);
    for (int i=0; i<k; i++) {
        fill(b, b+n+1, 0);
        int temp;
        scanf("%d", &temp);
        int num = count(temp, l);
        printf("%d\n", num);
    }
    return 0;
}

题后总结

  • 复习了广度优先遍历及其实际应用场景;
  • 终于可以写出和柳神一样短的代码了^_^||…;

猜你喜欢

转载自blog.csdn.net/rebornyp/article/details/80141683