[PAT]A1076 Forwards on Weibo——BFS

(PAT)1076 Forwards on Weibo (30 分)

一、原文

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.**

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.
Then finally a positive K is given, followed by K UserID’s for query.

Output Specification:
For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

二、分析

强烈建议不要使用DFS
1)可能一个结点A到B有多条路径,B到C只有一条路径,但是依照传播次数,可能漏解C。
2)DFS可能导致同一个结点的转发次数被重复计算。**

#include<cstdio>
#include<fstream>
#include<cstring>
#include<vector>
#include<queue>
using namespace std;
const int maxv=1010;
 
struct Node{
	int id;
	int layer;
};
 
vector<Node> adj[maxv];
bool inq[maxv]={false};
 
int BFS(int s, int L){
	int numforward=0;
	queue<Node> q;
	Node start;
	start.id=s;
	start.layer=0;
	q.push(start);
	inq[start.id]=true;
	while(!q.empty()){
		Node topnode=q.front();
		q.pop();
		int u=topnode.id;
		for(int i=0; i<adj[u].size(); i++){
			Node next=adj[u][i];
			next.layer=topnode.layer+1;
			if(inq[next.id]==false  && next.layer<=L){
				q.push(next);
				inq[next.id]=true;
				numforward++; 
			}
		}
	}
	return numforward;
}
 
int main(){
	Node user;
	int n, L, numfollow, idfollow;
//	freopen("d://in.txt","r",stdin);
	scanf("%d%d", &n, &L);
	for(int i=1; i<=n; i++){
		user.id=i;
		scanf("%d", &numfollow);
		for(int j=0; j<numfollow; j++){
			scanf("%d", &idfollow);
			adj[idfollow].push_back(user); 
		}
	}
	int numquery, s;
	scanf("%d", &numquery);
	for(int i=0; i<numquery; i++){
//就像每次判断都可以加return 0 一样,每次循环都可以重置数组
		memset(inq, false, sizeof(inq));
		scanf("%d", &s);
		int numforward=BFS(s, L);
		printf("%d\n", numforward);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/lyly1995/article/details/87870890