PAT--1076 Forwards on Weibo (30 分)

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5
#include <iostream>
#include <bits/stdc++.h>

using namespace std;

const int maxv = 1010;

struct People
{
    int id;      //结点编号
    int layer;   //结点层次
};

vector<People> Adj[maxv];   //邻接表
bool inq[maxv] = {false}; //是否已加入队列

int BFS(int s,int l){   //start为起始结点,l为层数上限
    int numForward = 0;  //转发数
    People start;    //定义起始结点
    queue<People> q;  //BFS队列

    start.id = s; //起始结点编号
    start.layer = 0;  //起始结点层数

    q.push(start);   //起始结点压入队列
    inq[start.id] = true; //队首结点出队
    while(!q.empty()){   
        People tmp = q.front();  //取出队首的结点
        q.pop();   //队首结点出队

        int u = tmp.id;   //队首结点编号
        for(int i=0;i<Adj[u].size();i++){
            People next = Adj[u][i];  //从u出发到达的结点
            next.layer = tmp.layer+1;  //next的层号等于当前结点层号加1

            //如果next未加入到队列,且next的层数不超过上限l
            if(inq[next.id]==false && next.layer<=l){
                q.push(next);
                inq[next.id] = true;
                numForward++;
            }
        }
    }
    return numForward;

}

int main()
{
    int n,l,numFollow,idFollow;
    People usertmp;

    cin>>n>>l;
    for(int i=1; i<=n; i++)
    {
        usertmp.id = i;
        cin>>numFollow;
        for(int j=0; j<numFollow; j++)
        {
            cin>>idFollow;
            Adj[idFollow].push_back(usertmp); //usertmp--->i
        }
    }

    int numQuery,s;
    cin>>numQuery;

    for(int i=0; i<numQuery; i++)
    {
        memset(inq,false,sizeof(inq));
        cin>>s;
        int numForward = BFS(s,l);
        cout<<numForward<<endl;

    }


    //cout << "Hello world!" << endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/jackson_j/article/details/100054842