1076 Forwards on Weibo (30)(30 分)

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=1000), the number of users; and L (<=6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (<=100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that are followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5


看懂题意很重要,要计算 L层以内的follower的数量,bfs+邻接表(省时间)。
代码:
#include <cstdio>
#include <vector>
#include <queue>
#include <algorithm>
#include <map>
#include <iostream>
using namespace std;
int n,l;
vector<int> v[1005];///邻接表
typedef pair<int,int> pa;///方便队列使用
int bfs(int d) {
    queue<pa> q;
    q.push(pa(d,0));
    int c = 0;
    bool vis[1005] = {false};
    vis[d] = true;
    while(!q.empty()) {
        int level = q.front().second;
        int present = q.front().first;
        q.pop();
        for(int i = 0;i < v[present].size();i ++) {
            if(!vis[v[present][i]]) {
                if(level + 1 <= l) {///满足
                    c ++;
                    vis[v[present][i]] = 1;
                    q.push(pa(v[present][i],level + 1));
                }
            }
        }
    }
    return c;
}
int main() {
    int m,d;
    scanf("%d%d",&n,&l);
    for(int i = 1;i <= n;i ++) {
        scanf("%d",&m);
        for(int j = 1;j <= m;j ++) {
            scanf("%d",&d);
            v[d].push_back(i);
        }
    }
    int k;
    scanf("%d",&k);
    for(int i = 0;i < k;i ++) {
        scanf("%d",&d);
        printf("%d\n",bfs(d));
    }
}

猜你喜欢

转载自www.cnblogs.com/8023spz/p/9207266.html