【PAT A1076】Forwards on Weibo

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:
where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.
Then finally a positive K is given, followed by K UserID’s for query.
Output Specification:
For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.
Sample Input:
7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6
Sample Output:
4
5

/*
 * 【PAT A1076】Forwards on Weibo
 *
 * */
#include "cstdio"
#include "cstring"
#include "vector"
#include "queue"
using namespace std;
const int MAXV=1010;
struct Node{
    int id;//节点编号
    int layer;//节点层号
};
//图使用邻接表存储
vector<Node> Adj[MAXV]; //邻接表
bool inq[MAXV]={false};//判断节点是否已经加入过队列
//采用BFS遍历图
int BFS(int s,int L){
    //起始节点和层数上限
    int numForward=0;//转发数
    queue<Node> q;//BFS队列
    Node start;//起始节点
    start.id=s;
    start.layer=0;
    q.push(start);//起始节点压入队列
    inq[start.id]=true;//设为已经访问
    while(!q.empty())
    {
        Node topNode=q.front();//取出队首节点
        q.pop();//队首节点出队
        int u=topNode.id;//队首节点编号
        for(int i=0;i<Adj[u].size();i++)
        {
            Node next=Adj[u][i];//队首节点能到达的下一节点
            next.layer=topNode.layer+1;
            if(inq[next.id]== false&&next.layer<=L)
            {//下一个节点未访问并且层数不超限制
                //则入队
                q.push(next);
                inq[next.id]=true;
                numForward++;//转发数加1
            }

        }
    }
    return numForward;
}
int main()
{
    Node user;
    int n,L,numFollow,idFollow;
    scanf("%d%d",&n,&L);//节点个数 层数上限
    for(int i=1;i<=n;i++)
    {
        user.id=i;
        scanf("%d",&numFollow);//用户关注的人数
        for(int j=0;j<numFollow;j++)
        {
            scanf("%d",&idFollow);//用户关注的节点编号
            Adj[idFollow].push_back(user);//idFollow 被关注 所发内容可以被user转发
        }
    }
    int numQuery,s;
    scanf("%d",&numQuery);//查询个数
    for(int i=0;i<numQuery;i++)
    {
        memset(inq,false, sizeof(inq));//数组初始化
        scanf("%d",&s);//起始节点编号
        int numForward=BFS(s,L);
        printf("%d\n",numForward);//输出转发数
    }
    return  0;
}
/*
7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6
 */

测试结果:
在这里插入图片描述

发布了51 篇原创文章 · 获赞 1 · 访问量 6054

猜你喜欢

转载自blog.csdn.net/qq_39827677/article/details/104276235