PAT甲级 —— 1076 Forwards on Weibo (30分)

  • 题目链接:Forwards on Weibo (30分)

  • 题目描述

    Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

  • Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:M[i] user_list[i] where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.
    Then finally a positive K is given, followed by K UserID’s for query.

  • Output Specification:

    For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

  • Sample Input:

    7 3
    3 2 3 4
    0
    2 5 6
    2 3 1
    2 3 4
    1 4
    1 5
    2 2 6

  • Sample Output:

    4
    5

  • 题意:微博中用户直接有相互关注形成的关系网,一条微博可能被关注发布者的用户转发,转发的信息又可能被关注转发者的用户再次转发。规定发布者不能转发自己的微博,每个人转发同一条微博最多一次。现在给出N个用户的关注列表、转发层数上限及微博发布者编号,输出最大转发数量

  • 分析:

    1. 关注是一个单向的动作,若X关注了Y,应当建立Y到X的有向边,表示Y发表的微博对X可见
    2. 转发层次明显地提示用BFS进行图遍历
    3. 关于BFS遍历图,参考:【算法笔记】10.3 图的遍历
  • 满分代码

    #include<iostream>
    #include<queue>
    using namespace std;
    
    const int MAXN = 1010;
    bool inqueue[MAXN] = {
          
          false}; 
    int CNT = 0;
    
    typedef struct NODE{
          
          
    	int v;		//连接到的端点 
    	int layer;	//层次 
    	
    	NODE(int _v,int _layer):v(_v),layer(_layer){
          
          }
    }NODE;
    
    vector<NODE> Adj[MAXN];
    
    void BFS(int s,int depth)
    {
          
          
    	queue<NODE> q;
    	NODE start = NODE(s,0);
    	q.push(start);
    	inqueue[s] = true;
    	
    	while(!q.empty()) 
    	{
          
          
    		NODE top = q.front();
    		q.pop();
    		if(top.layer>=depth)
    			break;
    			
    		for(int i=0;i<Adj[top.v].size();i++)
    		{
          
          
    			NODE next = Adj[top.v][i];
    			if(!inqueue[next.v])
    			{
          
          
    				CNT++;
    				next.layer = top.layer+1;
    				q.push(next);
    				inqueue[next.v] = true;
    			}				
    		} 
    		
    	}
    }
    
    int main()
    {
          
          
    	int N,depth;	//人数、转发层数
    	cin>>N>>depth;
    	
    	int num,followed; 
    	for(int i=1;i<=N;i++)
    	{
          
          
    		cin>>num;
    		for(int j=0;j<num;j++)
    		{
          
          
    			cin>>followed;
    			Adj[followed].push_back(NODE(i,0));
    		}
    	} 
    	
    	int query,begin;//查询个数、查询起点 
    	cin>>query;	
    	for(int q=0;q<query;q++)
    	{
          
          
    		fill(inqueue,inqueue+MAXN,false);
    		CNT = 0;
    		cin>>begin;
    		BFS(begin,depth);
    		cout<<CNT<<endl;
    	}	
    	
    	return 0;
    }
    
    /*
    7 3
    3 2 3 4
    0
    2 5 6
    2 3 1
    2 3 4
    1 4
    1 5
    2 2 6
    
    */
    

猜你喜欢

转载自blog.csdn.net/wxc971231/article/details/108591843