1154 Vertex Coloring (25 分)

版权声明: https://blog.csdn.net/ysq96/article/details/89634436

proper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

题意:proper vertex coloring即是图中任意相邻的两点的颜色不能相同,用unordered_set记录整个图有多少的颜色,即是最后的k-coloring,如果图中出现了相邻两点颜色一样则直接输出NO即可

C++:

#include"iostream"
#include"unordered_set"
#include"vector"
#include"algorithm"
using namespace std;
const int maxn=10010;
struct node{
	int a,b;
};
int main(){
	int n,m;
	vector<node> edge;
	scanf("%d %d",&n,&m);
	for(int i=0;i<m;i++){
		int a,b;
		node temp;
		scanf("%d %d",&a,&b);
		temp.a=a;
		temp.b=b;
		edge.push_back(temp);
	}
	int k;
	scanf("%d",&k);
	for(int i=0;i<k;i++){
		unordered_set<int> book;
		vector<int> color(n);
		int flag=1;
		for(int j=0;j<n;j++){
			scanf("%d",&color[j]);
			book.insert(color[j]);
		}
		for(int j=0;j<m;j++){
			int a=edge[j].a,b=edge[j].b;
			if(color[a]==color[b]){
				flag=0;
				break;
			}
		}
		if(flag==0)
			printf("No\n");
		else
			printf("%d-coloring\n",book.size());
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ysq96/article/details/89634436
今日推荐