PAT甲级--1154 Vertex Coloring (25 分)【hash】

proper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

题意:有n个点,m条边,相邻的点不能相同的颜色,然后有k种涂颜色的方法,如果符合条件的话,就输出这种方案总共涂了几个颜色,如果不符合就输出No

解题思路:先结构体存储边即v,w,然后在判断每一种符不符合的时候,输入的每一种颜色都放到set里面,然后hash判断a[v[i].v]==a[v[i].w],如果相等就说明不符合直接退出循环输出No,不等的话就输出set的size

#include<iostream>
#include<cstdio>
#include<vector>
#include<set>
using namespace std;
const int maxn=1e4+1;
struct vertex{
	int v,w;
};
int main(void)
{
	int n,m;
	scanf("%d %d",&n,&m);
	vector<vertex>vq(m);
	for(int i=0;i<m;i++)
	scanf("%d %d",&vq[i].v,&vq[i].w);
	
	int k;
	scanf("%d",&k);
	while(k--)
	{
		int a[maxn]={0};
		set<int>ans;
		for(int i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
			ans.insert(a[i]);
		}
		bool flag=true;
	    for(int i=0;i<m;i++)
        {
        	if(a[vq[i].v]==a[vq[i].w]) 	
			{
			    flag=false;
				break;	
			}
		}
		if(flag) printf("%d-coloring\n",ans.size());
	    else printf("No\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Imagirl1/article/details/85412907