18年冬季第三题 PAT甲级 1154 Vertex Coloring (25分) 两种思路

题目来源:https://pintia.cn/problem-sets/994805342720868352/problems/1071785301894295552

备考汇总贴:2020年3月PAT甲级满分必备刷题技巧

proper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

题目大意(本栏、思路一及其代码源自liuchuo,我改得更通顺和好懂)

给出一个图(即给出所有边),然后给出多种图着色的查询,问是否满足 k个颜色的图着色(i.e. 涂上k个颜色后,所有的边的两个点的颜色不相同),如果满足还要指明k是多少。

题目分析

思路一:把所有边存起来,把所有点的颜色存起来(存的过程中放入set统计颜色个数),枚举所有边,检查是否每条边的两点个颜色是否相同;若全不相同,则输出颜色个数k,否则输出No

思路二:用邻接表的方式存图(双重vector),访问每个顶点的邻接顶点,如果存在颜色相同就输出No;如果全部都不同,就输出颜色个数k,否则输出No

满分代码

思路一

#include <iostream>
#include <vector>
#include <set>
using namespace std;
struct node {int t1, t2;};
int main() {
    int n, m, k;
    cin >> n >> m;
    vector<node> v(m);
    for (int i = 0; i < m; i++)
        scanf("%d %d", &v[i].t1, &v[i].t2);
    cin >> k;
    while (k--) {
        int a[10009] = {0};
        bool flag = true;
        set<int> se;
        for (int i = 0; i < n; i++) {
            scanf("%d", &a[i]);
            se.insert(a[i]);
        }
        for (int i = 0; i < m; i++) {
            if (a[v[i].t1] == a[v[i].t2]) {
                flag = false;
                break;
            }
        }
        if (flag) 
            printf("%d-coloring\n", se.size());
        else 
            printf("No\n");
    }
    return 0;
}

思路二

#include<iostream>
#include<vector>
#include<set>
using namespace std;
int main(){
    int n,m,k,a,b;
    scanf("%d %d",&n,&m);
    vector<vector<int>> v(n);
    for(int i=0;i<m;i++){
        scanf("%d %d",&a,&b);
        v[a].push_back(b);
        v[b].push_back(a);
    }
    scanf("%d",&k);
    for(int i=0;i<k;i++){
        vector<int> t(n);
        set<int> kc;
        for(int j=0;j<n;j++){
            scanf("%d",&t[j]);
            kc.insert(t[j]);
        }
        bool flag=true;
        for(int j=0;j<n;j++){
            for(auto it:v[j]){
                if(t[it]==t[j]){
                    flag=false;
                    break;
                }
            }
        }
        if(flag)printf("%d-coloring\n",kc.size());
        else printf("No\n");
    }
    return 0;
}

 

备考汇总贴:2020年3月PAT甲级满分必备刷题技巧

如果喜欢我的博客,请为我点个赞,也欢迎多评论、转发,感谢!!

猜你喜欢

转载自blog.csdn.net/allisonshing/article/details/104799581