【PAT甲级】1154 Vertex Coloring (25 分)(set容器)

版权声明:本人大三在读,有错误烦请指正,共同进步- ( ゜- ゜)つロ 乾杯~点赞请按右上角,转载请标明出处: https://blog.csdn.net/hzyhfxt/article/details/87971322

1154 Vertex Coloring (25 分) 

A proper vertex coloring is a labeling of the graph’s vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10
​4
​​ ), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:
For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:
10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9
Sample Output:
4-coloring
No
6-coloring
No 

 题意:

一条边的两端颜色一样就输出“No”,颜色都不相同就输出颜色的种类

注意点:

set要清空,不请空就0分。。。 真是一念之间

#include <cstdio>
#include <iostream>
#include <set>
#define go(i,a,b) for(int i=a;i<=b;i++)
using namespace std;
const int maxn = 1e4 + 5;
typedef struct{
    int x,y;
} node;
node a[maxn];
set<int>s;
int main()
{
    int n,m,k;
    scanf("%d%d",&n,&m);
    go(i,0,m-1)
    {
        scanf("%d%d",&a[i].x,&a[i].y);
    }
    scanf("%d",&k);
    while(k--)
    {
        int b[maxn];
        int f = 0;
        s.clear();
        go(i,0,n-1)
        {
            scanf("%d",&b[i]);
            s.insert(b[i]);
        }
        go(i,0,m-1)
        {
           if(b[a[i].x] == b[a[i].y])
           {
               f = 1;
               cout<<"No"<<endl;
               break;
           }
        }
        if(!f)printf("%d-coloring\n",s.size());
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/hzyhfxt/article/details/87971322