Advanced Fruits(HDU1503)

Problem Description

The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them. 
A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property. 
A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example. 
Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names. 

Input

Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.

Input is terminated by end of file. 

Output

For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.

Sample Input

apple peach 
ananas banana 
pear peach

Sample Output

appleach 
bananas 
pearch

题解:模板代码的变形,我也是看了网上大佬的代码才会的,用vis数组标记dp数组,保证每个元素都会输出。

代码如下:

#include <iostream>
#include <cstdio>
#include <stdlib.h>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <string.h>
#include <vector>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <ctime>
#define maxn 1007
#define N 100005
#define INF 0x3f3f3f3f
#define PI acos(-1)
#define lowbit(x) (x&(-x))
#define eps 0.000000001
#define read(x) scanf("%d",&x)
#define put(x) printf("%d\n",x)
#define Debug(x) cout<<x<<" "<<endl
using namespace std;
typedef long long ll;
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

char s1[1000],s2[1000];
int l1,l2,dp[1000][1000],vis[1000][1000];

void qaq(int i,int j)
{
    if(!i && !j)
        return ;
    if(vis[i][j]==0)
    {
        qaq(i-1,j-1);
        cout<<s1[i-1];
    }
    else if(vis[i][j]==1)
    {
        qaq(i-1,j);
        cout<<s1[i-1];
    }
    else
    {
        qaq(i,j-1);
        cout<<s2[j-1];
    }
}
void LCS()
{
    int i,j;
    for(int i=0;i<=l1;i++)
        vis[i][0]=1;
    for(int i=0;i<=l2;i++)
        vis[0][i]=-1;
    for(i = 1; i<=l1; i++)
    {
        for(j = 1; j<=l2; j++)
        {
            if(s1[i-1]==s2[j-1])
            {
                dp[i][j] = dp[i-1][j-1]+1;
                vis[i][j]=0;
            }
            else if(dp[i-1][j]>=dp[i][j-1])
            {
                dp[i][j] = dp[i-1][j];
                vis[i][j]=1;
            }
            else
            {
                dp[i][j] = dp[i][j-1];
                vis[i][j]=-1;
            }
        }
    }
}

int main()
{
    while(cin>>s1>>s2)
    {
        l1 = strlen(s1);
        l2 = strlen(s2);
        memset(dp,0,sizeof(dp));
        memset(vis,0,sizeof(vis));
        LCS();
        qaq(l1,l2);
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/baiyi_destroyer/article/details/81186737