lightoj1236唯一分解定理求公约数等于n的对数

Find the result of the following code:

long long pairsFormLCM( int n ) {
    long long res = 0;
    for( int i = 1; i <= n; i++ )
        for( int j = i; j <= n; j++ )
           if( lcm(i, j) == n ) res++; // lcm means least common multiple
    return res;
}

A straight forward implementation of the code may time out. If you analyze the code, you will find that the code actually counts the number of pairs (i, j) for which lcm(i, j) = n and (i ≤ j).

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 1014).

Output

For each case, print the case number and the value returned by the function 'pairsFormLCM(n)'.

Sample Input

15

2

3

4

6

8

10

12

15

18

20

21

24

25

27

29

Sample Output

Case 1: 2

Case 2: 2

Case 3: 3

Case 4: 5

Case 5: 4

Case 6: 5

Case 7: 8

Case 8: 5

Case 9: 8

Case 10: 8

Case 11: 5

Case 12: 11

Case 13: 3

Case 14: 4

Case 15: 2

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;

const int maxn=1e7+1;
typedef long long ll;
 int p[maxn/10],cnt;
bool vis[maxn];


void init()
{
    cnt=0;
    memset(vis,0,sizeof(vis));
    for(int i=2;i<maxn;i++)
    {
        if(!vis[i])
        {
            p[cnt++]=i;
            for(int j=i+i;j<maxn;j+=i)
              vis[j]=1;
        }
    }
}
int solve(ll x)
{int ans=1;
for(int i=0;i<cnt&&p[i]*p[i]<=x;i++)
{
    int e=0;
    while(x%p[i]==0)
    {
        e++;
        x/=p[i];
    }
    ans*=(2*e+1);
}
if(x>1)
    ans*=(2*1+1);
    return ans;
}
int main()
{int t;
    scanf("%d",&t);
    int w=0;
    init();
    while(t--)
    {ll n;
    int t;
        w++;
    scanf("%lld",&n);
    ll ans=solve(n);
    ll sum=(ans+1)/2;
    printf("Case %d: %d\n",w,sum);

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/89810473
今日推荐